Stumble off idle

Engine, transmission, transfer case, axles.
Suspension, coils, leafs, mods, upgrades.

Moderator: Bfix Staff Members

Post Reply
Dgrdurham88
Bfix "What's a Bronco?"
Bfix "What's a Bronco?"
Posts: 2
Joined: Sat Dec 10, 2016 4:11 pm

Stumble off idle

Post by Dgrdurham88 » Sat Dec 10, 2016 4:28 pm

Last week I got a "new to me" 1975 bronco. It was my wife's grandfathers bronco, and has a confirmed 77,000 original miles. Stock all around, 302 with motorcraft carb. I've got timing set to 12 degrees before TDC, once warmed up it idles very smooth, but only after backing out both mixture screws 4 turns. I also hook up a vac gauge and that's where I reach max vac. The problem is when I throttle up, it has a hesitation, and bogs down before it revs up. Only way I've been able to make it slightly better is to move the accelerator pump arm up to the top hole so it squirts down the carb throats sooner. This helped a lot, but it still has hesitation and bogs, but will stay running. It also pops a bit as it revs up. Any ideas where to proceed?

User avatar
Stan
BFix Locked and Loaded
BFix Locked and Loaded
Posts: 3620
Joined: Tue Jun 29, 2004 6:42 pm
Location: Boring Or

Post by Stan » Sun Dec 11, 2016 8:19 am

Have you checked for a vacuum leak ?
Have you checked to see if your timing is advancing beyond the 12*?
When you come to a fork in the road - take it
Homer - " Facts are meaningless . You could use facts to prove anything that's even remotely true."

Dgrdurham88
Bfix "What's a Bronco?"
Bfix "What's a Bronco?"
Posts: 2
Joined: Sat Dec 10, 2016 4:11 pm

Post by Dgrdurham88 » Sun Dec 11, 2016 6:40 pm

No vac leaks, and yes I confirmed today it is is advancing beyond 12* as it revs up. I adjusted everything on the carb as per the instructions on the rebuild kit. Pulled the plugs to check color, and found 6 to be pretty lean, and 2 to be black and fouled. The accelerator pump arm is supposed to be on hole 2, but in that position it bogs bad. If I put the arm to hole 4 at the top, it helps, but doesn't solve it. Also when in gear under a load it stumbles off idle and pops as it accelerates.

DirtDonk
BFix Locked and Loaded
BFix Locked and Loaded
Posts: 2759
Joined: Sun Jul 27, 2003 7:53 pm
Location: San Jose, CA
Contact:

Post by DirtDonk » Mon Dec 12, 2016 12:09 am

A malfunctioning PCV valve will sometimes do this. It's basically a big vacuum leak, so will act like one when it's not working properly. Or the wrong one was installed.
Has all the original smog stuff been removed by any chance? Could be the problem right there too. Since it's been doing it since before you got it, it's hard to know just how long, or what was done just prior to it starting to act up like this.

Have you performed the usual oil changes and full tune-up since you got it?
Some of the things that cause a stumble (including what's already been discussed) are:

1. vacuum leak.
2. Improper timing action such as the vacuum advance hooked up wrong
3. EGR valve malfunctioning.
4. Carburetor needing attention
5. Weak spark due to deteriorating ignition components
6. All of the above.

No telling what it needs at this point. Might have to get deeper into it.
How did you verify that there are no vacuum leaks?

Paul
'71 Bronco - 302 4v
3.5" WH/Skyjacker Lift
33 x 11.50 x15 Thornbirds on 15x7 Enkei's
Kayline soft top
Hanson bumpers
Dual batteries, Large 1G alt.

WWW.WILDHORSES4X4.COM :mrgreen:

Post Reply