Page 1 of 1

Under hood storage box

Posted: Fri Apr 18, 2014 1:33 pm
by Puff Daddy
Has anybody ever installed one of these?

http://www.wildhorses4x4.com/product/Un ... torage_Box

Tom

Posted: Fri Apr 18, 2014 10:56 pm
by DirtDonk
Should be somebody out there with one that can give you some feedback. We've sold quite a few over the years, of the various generations, so they're out there.
Now we just have to wait for someone with one to see your question.

Can't help you myself, because I've never installed one.
I'm debating whether to do it or not. On the one hand I like having the extra vent. On the other, well, storage space isn't exactly plentiful in an EB, so any extra is a big bonus!

Paul

Posted: Sat Apr 19, 2014 6:02 pm
by wesnjusa
I've got one installed. Works for what it is for. Haven't used it in a few years. It doesn't leak rain water or anything. I tend to forget what's in it.

Posted: Sun Apr 20, 2014 4:27 pm
by Puff Daddy
wesnjusa wrote:I've got one installed. Works for what it is for. Haven't used it in a few years. It doesn't leak rain water or anything. I tend to forget what's in it.
How did you seal the hole in the firewall...where the vent opening was? Also, did you use silicon to seal the top?

Posted: Sun Apr 20, 2014 4:36 pm
by wesnjusa
I don't remember sealing the hole, I'll check next time I have the cover off. I used some kind of silicon that seams to have worked prefect.

Posted: Sun Apr 20, 2014 4:39 pm
by Puff Daddy
At first I didn't think it would be a problem. Unfortunately it rained the next morning, and on the way home from work I had about one inch of water sloshing around the floorboards.

You should be able to see the hole behind the emergency brake.

Posted: Wed Apr 23, 2014 8:15 pm
by wesnjusa
I just went out and looked. I didn't see any hole in the firewall. The box hangs down to just above the bright switch. I may have filled the hole when I did my frame off. I know I filled a few holes in that area as I converted from a manual to an automatic. I don't remember it has been awhile since I did that work.

I did notice that it is leaking from the top. I guess I need to pull it and re-seal it.

Posted: Thu Apr 24, 2014 5:22 pm
by Puff Daddy
Thanks for the response. I've been trying to find a rubber or plastic plug that matches the size.